Known Problem: Fatal Error in GC

As this Unity-Related error still seems to appear after several years, here is some information on how to fix some of the Problems:

When using AVAST Antivirus: The problem seems to be caused by UPGRADING from Version 7 to Version 8 of AVAST. Problem fix appears to be Uninstall, reboot, Clean install. Source: ... -in-GC-Fix

Another Fix for Avast: Uncheck: Settings -> Toubleshooting -> Enable hardware-assisted virtualization. Source: ... #msg951968

When using ESET: Don't know if this still applies, but it seems that adding an Exclusion for WebAccess protection does the trick. Source and Step-by-Step-Guide: ... ost1107488

We had also reports of users that successfully prevented this from happening when running the game in "Compatible Mode" (which basically forces it to run in DX9 instead of DX11).

Another compatiblity mode that worked for some users was the windows compatibility mode. Try to run the file "schick.exe" in the installation directory directly, but with windows execution compatibility (Steam -> Library -> Right click to Realms of Arkania -> Properties -> Explore local files, then Right click to schick.exe -> Properties -> Compatibility) set to Windows Vista or even Windows XP. Backed up by Source: ... 006158/#p4

The earliest reported instance of a problem with the GC was discussed on the Unity Forums as early as 2009. Although I doubt that it is still the same problem, it seems to be a reoccuring problemset with Mono and Windows and certain AV Software in General. Anyways, if there are any further suggestions for the solution of this problem, even permanent ones, I'm happy to add them here or try them out.
Firefox ist immer schuld :)

Zurück zu „Archive“