You are not logged in.

1

Friday, March 10th 2017, 6:17am

Can't run the game [solved]

Hello there!
When I launch the game I get a pink screen and error. My machine is: i3 4160, gtx650, 12gb ddr3, running win7 x64 at 1280x1024 resolution.
I have attached the log files. Inside the archive you also have dxdiag, a screenshot with what I see when I launch the game ( 20170310070940_1.jpeg ) and a screenshot with the error ( error.png ).
Thanks for reading and I have a great day! :)
Razvan has attached the following file:

This post has been edited 1 times, last edit by "Razvan" (Mar 10th 2017, 3:48pm)


2

Friday, March 10th 2017, 7:18am

Hi Razvan,

thanks for your message and welcome to the forum!

The outputlog file contains a lot of messages like

-WARNING: Shader Unsupported: 'Hidden/Internal-DeferredShading' - Pass '' has no vertex shader
and
-This custom render path shader needs to have at least 2 passes.

I'm not an expert at all, but if I had to guess, I'd say that your graphics card might be too old. If you can't fix it with a driver update, I'm afraid you are not able to play the game with this card.

However, let's see what the experts say.

3

Friday, March 10th 2017, 9:26am

The vga drivers are up to date.
I also suspected that it's the shader version, but the thing is that the minimum specs on store page are listed as gtx560 - which has the same shader, opengl and directx support.

4

Friday, March 10th 2017, 10:09am

The game definetly should run with a gtx650.
What i am wondering about is, that DX9 is stated in those logs, but I think DX11 should be used, shouldn't it?

5

Friday, March 10th 2017, 10:11am

I quickly installed the game on Debian Jessie (same machine) and it runs just well (screenshots in attachments). I have only roamed in the game for a few minutes, but I'm glad that the GUI is greatly improved from Blade of Destiny. Keep up the good work!

Now, I prefer to play games on Windows, and if it's possible to find a fix for my issue, any help is welcomed!
Razvan has attached the following images:
  • 20170310105205_1.jpg
  • 20170310105300_1.jpg
  • 20170310105313_1.jpg
  • 20170310105408_1.jpg

6

Friday, March 10th 2017, 10:55am

The game requires DX11 on Windows because of some compatibility issues with DX9, so if you could try to install it, that should do the trick :).
Firefox ist immer schuld :)

7

Friday, March 10th 2017, 3:47pm

The game requires DX11 on Windows because of some compatibility issues with DX9, so if you could try to install it, that should do the trick :).

That solved it indeed! Thanks a lot for the solution, and thanks everyone for the replies!

PS: If anyone has a similar issue and sees this thread: update Windows. Or if only this isolated update is desired, the package is KB2670838